SSL化してたらエラーばっかりだけど、単純なミスだった

最近はサイトのSSL化が流行り、というか今後それが主流になっていくということでSSL化してみようと思いました。
本当はさっさとやればよかったんですけど、

  • まだいいでしょ
  • なんか難しそう

という2点が引っかかっていたので手をつけてませんでした。
ま、大して稼いでるアフィリエイターじゃないし。

とはいえ、「大して稼いでいない」からこそ今なら失敗しても痛くないんじゃないの?と思いまして。
所属しているオンラインサロンにも手順の動画もあるしそれを見ればきっと簡単にできるはず。
ということでメインサイトをいじるのは怖いので放置中のサイトでやってみました。

途中でつまづいて匙を投げたんですけど、時間を置いて再度進めてみたら案外簡単にできました。
というかちゃんと手順通りにやればできますね。
手順通りにやってなかった(漏れがあった)自分はエラーが出て当然だったというわけです。とほほ。

SSL化してみるよ

手順については検索すれば出てくるので細かくは省きます。

  1. サーバーからSSL化の申請
  2. サイトURLの変更
  3. プラグイン「Serch Regax」でhttp→httpsに一括変更
  4. サイトを右クリック「検証」でエラーを確認、修正していく

ざっとこれだけなんですけどね。

SSL化の申請

今回のサーバーはロリポップを使っているので、ロリポップにログインしてSSL化の申請を出します。
エックスサーバーだと1時間くらいかかるみたいですけど、ロリポップだと5分くらいで完了します。

サイトURLの変更

設定→一般でhttp〜のURLを「https」に変更する。
sを付けるだけだから別に難しいことはないですね。
「WordPress アドレス (URL)」、「サイトアドレス (URL)」両方変更します。

「Serch Regax」でhttp→httpsに一括変更

新しくSerch Regaxのプラグインを入れます。
入れた後は「ツール→Serch Regax」でサイトの全 URLをhttp→httpsに変更。

ヘッダー画像やプロフィール画像はSerch Regaxでは変更できないようなので、あとで1つづつ修正するようです。

検証でエラーをチェック

ここが問題でした。

エラーが出るのは予想内。
1つのページでSNSボタンがおかしくなっている。なんだろなーと思って調べているうちに直ったのでまぁいいかと思って次に進めようと思ったらまだ何かおかしい。
「保護された通信」と表示されない。Whyなぜに?

エラーが出る・・・

検証→Securityで見ると、いくつかおかしなことになっているらしい。

  • A8のリンクが変?
    アフィリのリンクは結構前に貼ったものだから飛び先が「http://〜」になっているからか?
    新しく貼り直してもダメそうなので一旦アフィリのリンクは全部外す
  • 元のhttp://〜のURLがおかしい?
    Security→Networkで見ると確かにhttp://〜のままのものがいくつかある。
    Elementsを表示させエラーのリンク(http://自サイト.com)を探してみるといっぱいhttp://〜のまま使われているなぁ。
    でもどう修正するのかよく分からない・・・。(テーマの編集でもできないし・・・)
  • 1.gravator.comがおかしい?
    こんなURL知らんぞ、と思ったらワードプレスの右上にあるプロフィール画像(「こんにちは、〇〇さん」の横にある画像)がhttpのままだという。
    こんなのどうやって修正するんじゃい。
  • h3タグの画像がおかしい?
    見出しをh3で表示させた時の左の画像自体がhttpになっているらしいがどうしろと・・・?

とまぁ色々ありましたが訳わかりませんでした。
ググってググって解決に近づいてきた?と思ってもやっぱりよく分からない。
これ以上SSL化つまづくのも時間がもったいない気がして保留決定・・・。

SSL化再トライ→できた

さて、週末になり仕事も休みなのでもう一回トライしてみます。
まずはSSL化手順のおさらいをオンラインサロンでざっとチェック。

そこに
「今回の手順は寝ログさんを参考にしました」
書いてあり早速リンクに飛んで確認。
で、ようやくSSL化していない原因がわかりました。

原因は、

「設定→一般」でサイトURLの変更をしていなかった
(ワードプレスのURLは変更していた)

でした。
うーわーアホすぎるー。
むしろオンラインサロンの動画の方でもちゃんとそう言っているのにできていない自分。
うっかりミスが多くて嫌になるなぁ・・・。

でも解決したのならオールOK。

と思いきや今度はメニューバーのリンクが「http」のまま。
これは最初にメニューバーを設定した時に「http://〜」でリンクを作ったからなので、ささっと「https」に修正。

というわけでこれでSSL化できた。
結論としては、

「ちゃんと漏れなく手順を踏みましょう」

ということでしょうかね。
じゃないと原因究明で無駄な時間を過ごしますよ・・・(;´д`)

関連記事

いつの間にかAmazonプライムの会員になっていたので映画を観るようになった

リラックスしすぎる体勢でPC作業しない方がいいらしい

スマホのメモ帳が便利だから使わない理由がない

年が明けたので年頭所感でも

台風に翻弄された、20年目のサマソニに行ってきました。

今こそ再評価したいサッカー漫画「ANGEL VOICE」